Introduction - Another Newbie

New members please post here to introduce yourself. A warm welcome is guaranteed!
Post Reply
scotty2
Posts: 41
Joined: Mon Aug 21, 2017 2:50 pm

Introduction - Another Newbie

Post by scotty2 » Mon Sep 04, 2017 12:31 pm

Hi.

Just had my latest Beige BL classic delivered.
1.7 HL Ambassador. Got it on a second chance bid when buyer didn't...

download/file.php?mode=view&id=1438

Really solid all round but a carb issue. Anyone got a spare so I can rebuild the original at leisure. Something to do with cold start device.
The Ambassador joins an Allegro and Maxi also in beige. I also have a Metro VDP.
Attachments
Ambassador.jpg
Ambassador.jpg (52.41 KiB) Viewed 4500 times

User avatar
Gasman
Posts: 2047
Joined: Thu Aug 29, 2013 4:37 pm
Location: Shawford, Winchester, UK
Contact:

Re: Introduction - Another Newbie

Post by Gasman » Mon Sep 04, 2017 3:36 pm

Well done on acquiring. I don't understand how people win an auction and then don't collect. How do they get away with it? Anyway, it had a silver lining for you!

The 1700 engine only had a single carburettor with a manual choke or am I wrong. Lord Leyland, amongst others, will tell us. The Automatic Starting Unit ASU was only fitted to the twin carb VDP 2000 model and is an absolute pain but there's not much to go wrong with the manual choke. Whatever, I am afraid we don't have a spare carb for you.
Martin
Club Treasurer


Owner of:
Oldest known surviving wedge, hand-built 15th Pre-Production Wolseley in June 1974
Last Ambassador down the line in November 1983, Austin Ambassador VDP

User avatar
Tony c
Posts: 245
Joined: Fri Mar 18, 2016 7:33 pm
Location: Cheshire

Re: Introduction - Another Newbie

Post by Tony c » Mon Sep 04, 2017 8:49 pm

I have a few carbs if you still need one.
ASU was fitted to HLS models also,it really doesn't matter which model though,it was crap on them all imo!!

scotty2
Posts: 41
Joined: Mon Aug 21, 2017 2:50 pm

Re: Introduction - Another Newbie

Post by scotty2 » Tue Sep 05, 2017 12:08 pm

I've ordered a rebuild kit but will look out for a spare carb. Might have one on a mini manifold somewhere...

Yes it's single carb manual choke so I might be able to sort. OS Windscreen wiper has just stopped moving! Oh the joys of recommissioning.

Test_Gasman
Posts: 2
Joined: Thu Mar 27, 2014 9:54 pm

Re: Introduction - Another Newbie

Post by Test_Gasman » Fri Sep 08, 2017 9:10 am

Most likely the nut holding the wiper arm to the splines has come loose if the N/S wiper continues to work. The mechanism connecting the wipers from the motor to the splines the arms attach to is very sturdy and unlikely to have failed (famous last words).
Martin
Club Treasurer

scotty2
Posts: 41
Joined: Mon Aug 21, 2017 2:50 pm

Re: Introduction - Another Newbie

Post by scotty2 » Mon Sep 11, 2017 2:03 pm

Wiper fixed - loose.
Carb rebuilt and sorted.
Oil light worrying lit up frequently during the test runs, but a new sender switch seems to have cured that. Had the same issue with my Allegro.
Only comes on when cornering hard to the left now.
Cause of fuel problems:
001.jpg
001.jpg (42.93 KiB) Viewed 4452 times

Vulgalour
Posts: 1704
Joined: Wed Sep 26, 2012 7:28 pm

Re: Introduction - Another Newbie

Post by Vulgalour » Sun Sep 17, 2017 3:16 pm

Hello over here too!

scotty2
Posts: 41
Joined: Mon Aug 21, 2017 2:50 pm

Re: Introduction - Another Newbie

Post by scotty2 » Wed Aug 07, 2019 10:02 am

Just an update with my wheeltrims. Quite like the black and beige contrast.


a_800.jpg
a_800.jpg (148.13 KiB) Viewed 1433 times

Vulgalour
Posts: 1704
Joined: Wed Sep 26, 2012 7:28 pm

Re: Introduction - Another Newbie

Post by Vulgalour » Mon Sep 30, 2019 12:41 pm

Hooray! They look way better than the trims it came to you on. Nice matching Allegro too.

Post Reply